Status
Get in touch
Back
Maintenance
Infrastructure update.
Completed 13 Jun at 09:30pm CEST.
Affected services
developer.ebcom.ir
Completed
Maintenance completed
Posted 13 Jun at 09:30pm CEST.
Started
Hardware update.
Posted 13 Jun at 08:00pm CEST.